Support Center
 Knowledgebase
Support Center
Technical Requirements
Melissa Gajarsa August 10 2017 09:02 AM

To use this database you must have an Internet-accessible PC or Macintosh computer running an Internet browser. For the best results, we recommend that you download the most current version of browsers, Adobe Reader (for viewing PDFs)  Adobe Flash or an HTML5-compatible browser (for viewing videos), and QuickTime (for the Read Aloud feature) which are available as free downloads. The database and its videos can also be viewed on an Internet-connected mobile device.

 

 Minimum Requirements

  • Browsers: On PCs we support Internet Explorer 8.0 or higher (Internet Explorer 9.0 or higher is required for Interactive Experiments), Firefox and Chrome; on Macintosh computers we support Safari 5.1 or higher.
  • PDFs: We support Adobe Reader 9.0 or higher for viewing PDFs.
  • Videos: We support Adobe Flash Player 11.0 or higher or an HTML5-compatible browser for viewing videos.
  • Read Aloud: We support QuickTime 7.0 for using the Read Aloud feature. Currently, Read Aloud is not compatible with IOS devices or with 64-bit browsers.
  • General: Javascript and cookies need to be enabled & Broadband Internet Connection Required.

 

If you are experiencing issues with videos, please make sure you meet all minimum requirements:

 

Windows

  • Processor: 2.33GHz or faster x86-compatible processor or x64 1.6-gigahertz (GHz) or higher processor
  • Operating System: Windows 7, Windows 8, Windows 10
  • RAM: 2-4GB recommended
  • Video Card: 128 MB minimum
  • Screen Resolution: 800 x 600 minimum (1280 x 1024 recommended)
  • 16-bit sound card & Speakers/headphones

 

Mac

  • Processor: Intel Core™ Duo 1.83GHz or faster processor
  • Operating System: Mac OSX v 10.6 or higher
  • RAM: 512 MB minimum (2-4GB recommended)
  • Video Card: 128 MB minimum
  • Screen Resolution: 800 x 600 minimum (1280 x 1024 recommended)
  • 16-bit sound card & Speakers/headphones

system requirements

(0 vote(s))
Helpful
Not helpful