Support Center
 Knowledgebase
What are the viewing/listening requirements?
January 21 2014 04:47 PM

The Issues & Controversies database supports Internet Explorer 8.0 or higher, Firefox 10.0 or higher, and Safari 5.1 or higher. For viewing PDFs, we support Adobe Reader 9.0 or higher. For best results, we recommend that you use the most current version of your web browser and Adobe Reader, which are available as free downloads. For viewing videos, we support Adobe Flash Player 11.0 or higher, and for listening to audio using the Read Aloud function, we support QuickTime. Read Aloud is not currently supported on the iPad.

(2 vote(s))
Helpful
Not helpful